Logitech Harmony
Incident Report for Stringify
Resolved
Logitech has resolved this issue.
Posted about 1 year ago. Jan 02, 2018 - 14:27 PST
Investigating
We are significant errors communicating with Logitech.
Posted about 1 year ago. Dec 18, 2017 - 20:45 PST