Flows not executing (was: Flows not showing up)
Incident Report for Stringify
Resolved
This incident has been resolved.
Posted 7 days ago. Mar 14, 2019 - 10:12 PDT
Monitoring
Our downstream processes have now caught up to real time.

If you have flows that still aren't executing, please try the following troubleshooting steps:
* Disable / Re-Enable the flow
If that does not work,
* Create a duplicate flow using the "Duplicate" feature of our app. This will create a copy that will be disabled. When the copy is created, delete the original and enable the copy.

If you create a copy of a flow that uses IFTTT you will have to visit IFTTT to re-associate your applets to the duplicate copies. If a flow contains Alexa, you may have to "Alexa, discover".

Let us know if something still isn't working for you and we can troubleshoot, but please mention in your support case that you've followed these steps.
Posted 11 days ago. Mar 10, 2019 - 04:27 PDT
Update
First of all, I'd like to thank everyone personally for their patience. I know Stringify is the center of many of your home automations, and I know the frustration when things don't work. I know my significant other was a nay-sayer when it came to automating things, but now she can't live without them :).

Existing flows (made before ~5PM PST 8 March) will likely work by re-enabling them.

New flows are likely still not working. We've got processes that monitor new flows and push the data down to the third party integrations. These processes usually complete in a matter of seconds, but they are currently backed up hours. I'm finally seeing the process graphs top off, hopefully they'll begin the downward decline toward seconds overnight and into tomorrow.

We're still identifying the root cause of a significant % of our flows database table suddenly disappearing. We've taken steps to make sure that we can restore to a specific point in time instead of just taking snapshots daily. By taking snapshots daily, we have to depend on many secondary processes when we have to do a restore. In the future, we'll be able to restore all data in a matter of a few hours with no secondary processes required.

-Kris
Posted 11 days ago. Mar 09, 2019 - 19:21 PST
Update
We expect the system to remain in a degraded state throughout the day as we continue our recovery. If your flows are not running, disabling them and re-enabling them _may_ resolve this for you. We ask that you do not open support cases if it does not until we report the system is fully operational.
Posted 12 days ago. Mar 09, 2019 - 06:34 PST
Update
Flows should now show up in the app, but they may not yet be executing. We are now running our secondary provisioning functions and will provide another update in the morning.

It is now safe to create new flows and/or edit existing flows, but flows may still not execute.
Posted 12 days ago. Mar 08, 2019 - 23:28 PST
Update
We are about 50% done restoring our primary Flow table. Once that is complete, we need to run some integrity checks to make sure all downstream processes have the data they need. This secondary process may take all night - or longer. We'll have a better ETA once the process starts.

Flows may not properly execute until the entire process is complete.
Posted 12 days ago. Mar 08, 2019 - 21:21 PST
Update
We have experienced data loss in our flows database table. We will be restoring this table from backup. We expect this restore process to take several hours.

All flows created since approximately 3AM PST on 8 Mar will need to be re-created. We recommend NOT modifying any flows until we have updated this status message saying the restore is complete.
Posted 12 days ago. Mar 08, 2019 - 18:55 PST
Investigating
We are receiving reports of flows not showing up. We are investigating.
Posted 12 days ago. Mar 08, 2019 - 18:16 PST